First Steps

You’ve just discovered Makinom, now what?

Since Makinom is an editor extension for Unity, this documentation assumes that you’ll know the basics of Unity. If you’re looking for tutorials and learning materials on Unity, head over to their website.

Importing Makinom #

Importing Makinom into your Unity project works like importing any other asset. Depending on the used Unity version, you can import it from the Asset Store window or the Unity Package Manager.

If you’ve got Makinom as a unitypackage file or want to import an extension or plugin for Makinom (e.g. a new UI module) from a unitypackage file, just drag the file into your Unity window and drop it over the Project tab to start the import process.

Makinom will import it’s core functionality and editor (in form of DLL files), the Unity UI module (also in form of DLL files) and gizmo icons for components and data assets.

UI Modules #

Makinom comes with the Unity UI module as part of the standard import.

If you don’t want to use it you can skip importing it by disabling the UI module DLL files in the import window:

  • Assets/Gaming Is Love/Makinom 2/DLL/Makinom2.UnityUI.dll
  • Assets/Gaming Is Love/Makinom 2/DLL/Editor/Makinom2Editor.UnityUI.dll

Opening Makinom #

Once imported, you can open the Makinom editor via Unity’s menu: Window > Makinom

Open multiple Makinom editor windows via: Window > Makinom (Multi-Window)

This can be useful if you want to compare settings side-by-side or open multiple schematics.

Alternatively, you can also open the Makinom editor via keyboard shortcuts (displayed beside the Unity menu items). The shortcuts will depending on the operating system you’re working on, e.g. in Windows you can open Makinom via Ctr + Alt + M and Ctrl + Alt + Shift + M (for multi-window use).

Learn more in the Makinom editor documentation.

First Opening #

The first time you open the Makinom editor in a Unity project will automatically create 2 assets in Makinom’s data folder: Assets/Gaming Is Love/_Data/

  • Project.asset
    This is your Makinom project asset, it’ll be used by Game Starters to initialize Makinom in your running game.
    It holds some project settings and references.
  • EditorData.asset
    This is a purely editor-related asset and is not used in a running game.
    It holds only editor data, e.g. the drag area sizes, variable key references or the list of last opened schematics.

The project asset will remain blank/empty until you save in the Makinom editor (which will also save additional data assets).

Selecting a UI System #

One of the first things you should do after importing Makinom is selecting the UI system you want to use. While Makinom comes with the Unity UI module, it doesn’t have it selected in a new project.

Go to UI > UI System in the editor and select the UI module you want to use in the UI System Type setting.

Changing the UI system will prompt a confirmation dialogue:

Using a different UI system will cause UI related settings to change, discarding previous setup. This is mainly the case in UI boxes and HUDs, where part of their setup depends on the used UI system, but can also impact the setup of UI related schematic nodes.

Learn more about the UI system here.

First Save #

The first time saving will create additional assets in sub-folders of Assets/Gaming Is Love/_Data/.

The individual settings of list content (e.g. input keys or UI boxes) are saved in their individual data assets. E.g. each input key will have it’s own data asset in the Input Key sub-folder.

To save the settings, click on the Save Settings button in the bottom right of the Makinom editor window. This’ll show you the changes that will be saved and offer some additional options (more on them below).

Since it’s the first save, it’ll show a long list, since everything is new.

Learn more about saving settings in the Makinom editor documentation.

Scene Wizard #

Makinom’s scene wizard is a small window to help you add Makinom game objects or components to your scenes.

Open it using the Unity menu: Window > Makinom Scene Wizard

You can open the scene wizard via a keyboard shortcut, e.g. in Windows: Ctrl + Alt + W

The scene wizard allows you to create new game objects with already added Makinom components (e.g. music players, scene changers, etc.), add components and machines to selected game objects, create new camera positions by using a scene camera and a game object as references, test formulas using 2 game objects in your scene (for position related mechanics) and add a game starter to your scene.

The scene wizard can also display help texts from Makinom settings you hover over. E.g. help texts from inspectors can be displayed that way without having the Makinom editor opened.

Extension Manager #

The extension manager can be used to browse, download and import available extensions (e.g. plugins, custom nodes, other scripts or schematics) for Makinom.

Open it using the Unity Menu: Window > Makinom Extension Manager

Make sure to save your open Makinom project or schematics (in the Makinom editor) before importing any package, as importing a package will reset all unsaved changes.

Adding a Game Starter #

To use Makinom in your running game, you need to initialize it before being able to access any functionality (e.g. a machine running a schematic).

Initializing Makinom in your scene is done using a Game Starter component, which selects the Makinom project asset that should be used.

Add game startes using the scene wizard or simply add the component via Unity’s component menu: Makinom > Scenes > Makinom Game Starter

You can have a game starter in each of your scenes to be able to hit play in the Unity editor right there, once Makinom is initialized, other game starters will not be used.

Learn more about game starters here.

Getting Started #

You’re probably eager to try out Makinom – but where to start?

The best place to start is reading the basic documentations on schematics and machines to learn about the core concept of the workflow. You might also want to look into the Makinom editor to get an overview of the available features and where to find the functionality you’re looking for, as well as the node editor (which you’ll use most of the time).

Beginner Tutorials #

Once you’ve grasped the basics, or just skipped all that reading (learning by doing is also a good way to start), you can start with the easiest tutorial series and create a small Breakout game.

A bit more complex, but also for beginners is the Space Shooter tutorial.

Intermediate Tutorials #

If you’re looking for something more challenging, try the Match 3 tutorial. It contains advanced mechanics with in-schematic machine starting and selected data.

The Survival Shooter tutorial features a different set of advanced mechanics, e.g. raycasting (for shooting hit detection), enemy movement and spawning.

Advanced Tutorials #

For more complex tutorials, try the 2D Roguelike or 2D Platformer tutorials.